Inbound calling possible outage
Incident Report for Improcom
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 16:53 UTC
Identified
The carrier provided an update that the problem was identified and isolation efforts are being conducted
Posted Mar 31, 2022 - 13:20 UTC
Investigating
Some customers might have issues with incoming calls. The issue is on the carrier side and its engineers are investigating the problem now. Please, note that this is one of many carriers that we use, so you might not be affected by this issue.
Posted Mar 31, 2022 - 11:25 UTC
This incident affected: Voice services (Inbound Calls).