Incoming calls issues for some customers - no audio
Incident Report for Improcom
Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 15:42 UTC
Investigating
We are currently investigating this issue.
Posted Feb 09, 2022 - 14:29 UTC
This incident affected: Voice services (Voice Processing, Inbound Calls).