Carrier outage
Incident Report for Improcom
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 19:46 UTC
Update
Identified - The issue has been identified and a fix is being implemented. You may see some over your services restored.
Oct 1, 14:12 CDT
Posted Oct 01, 2021 - 19:32 UTC
Investigating
We are currently investigating this issue.
Posted Oct 01, 2021 - 16:42 UTC
This incident affected: Voice services (Voice Processing, Inbound Calls).