The issue was localized and resolved on local level. If you still have problems with incoming or outgoing calls, please reach out our support team support@improcom.com (best and quickest option), open a case https://improcom.helpspot.com or call 718-769-3400
Posted Jan 14, 2026 - 04:03 UTC
Identified
The carrier teams continue to work on the root issue causing inbound call failures for some customers. All appropriate teams are actively engaged. We will continue to keep http://status.improcom.com updated with the progress details.
Improcom Network Operations Center Jan 13, 2026 - 16:07 CST
Posted Jan 13, 2026 - 22:57 UTC
Update
The carrier has identified the underlying issue. Their engineers are continuing remediation efforts to eliminate the root cause and stabilize service. We are monitoring closely and will provide further updates as soon as we receive them.
Posted Jan 13, 2026 - 21:40 UTC
Investigating
One of our upstream carriers is having issues with incoming traffic. This is an update from them:
Update - We are investigating an issue causing inbound and outbound call failure at this time. We will keep this page updated as we have additional information. Jan 13, 2026 - 14:57 CST Investigating - engineering teams are currently investigating reports of inbound and outbound call failures for some customers. All appropriate teams are actively engaged.
Thank you, Improcom Network Operations Center
Posted Jan 13, 2026 - 21:01 UTC
This incident affected: Voice services (Voice Processing, Inbound Calls).