Upstream provider has issues with Incoming calls
Incident Report for Improcom
Resolved
The connectivity was restored. If you still experience issues with the incoming calls send us a ticket to support@improcom.com or call our support line 718-769-3400.
Posted Jan 05, 2022 - 17:00 UTC
Update
The carrier team is continuing to investigate the issue. They identified failed servers and actively replacing it now.
Posted Jan 05, 2022 - 16:46 UTC
Update
We are continuing to investigate this issue.
Posted Jan 05, 2022 - 16:02 UTC
Investigating
The provider is investigating the issue
Posted Jan 05, 2022 - 15:53 UTC
This incident affected: Voice services (Inbound Calls).