Inbound calls issues
Incident Report for Improcom
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 00:08 UTC
Identified
The carrier informed us that the major problem was fixed, but some numbers still may have issues. Engineers continue to work on the problem.
Posted Aug 10, 2022 - 20:56 UTC
This incident affected: Voice services (Inbound Calls).