Possible Verizon cell outage
Incident Report for Improcom
Resolved
This incident has been resolved.
Posted Mar 04, 2022 - 20:33 UTC
Identified
Apparently, Verizon has issues with the cellphone service. Multiple complaints that the calls from Verizon lines are dropping just after pickup. Improcom services are working normally. If you have any complaints check if the call was made from the Verizon cellphone line.
Posted Mar 04, 2022 - 18:35 UTC
This incident affected: Notifications.